Zephyr python netifaces install failure


Stephanos Ioannidis
 

Hi,

Please see https://github.com/zephyrproject-rtos/zephyr/issues/48584

building 'netifaces' extension
For now, unless you need to work with the "Intel CAVS" platform, which
actually requires this dependency, my suggestion would be to simply remove it
from the 'requirements-run-test.txt' file.

Another solution would be to use the Python 3.9 release for which the
'netifaces' package has a wheel (pre-built binary package).

Regards,

Stephanos


W Kicinski
 

I’m following the Zephyr getting started guide here:

https://docs.zephyrproject.org/latest/develop/getting_started/index.html

 

In the section “Get Zephyr and install Python dependencies” I’m following the directions for

Windows -> Install Globally

 

When I run the following:

pip3 install -r %HOMEPATH%\zephyrproject\zephyr\scripts\requirements.txt

 

I get the error:

  Running setup.py install for netifaces ... error

  error: subprocess-exited-with-error

 

  × Running setup.py install for netifaces did not run successfully.

  │ exit code: 1

  > [9 lines of output]

      C:\Users\wkicinski\AppData\Local\Programs\Python\Python39\lib\site-packages\setuptools\config\setupcfg.py:463: SetuptoolsDeprecationWarning: The license_file parameter is deprecated, use license_files instead.

        warnings.warn(msg, warning_class)

      running install

      C:\Users\wkicinski\AppData\Local\Programs\Python\Python39\lib\site-packages\setuptools\command\install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.

        warnings.warn(

      running build

      running build_ext

      building 'netifaces' extension

      error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/

      [end of output]

 

  note: This error originates from a subprocess, and is likely not a problem with pip.

error: legacy-install-failure

 

× Encountered error while trying to install package.

> netifaces

 

Choco installed python 3.10.  I installed the latest VS build tools, as well as the 2019 build tools with v14.2 compiler.

I still keep getting this error.  I’m on Windows 11.

 

Is there a known solution to this issue?

 

Thanks & Regards,

Walt Kicinski